Home > No Sound > Amplifier Not Working No Sound

Amplifier Not Working No Sound

Contents

Open circuit? eventually ill move on to Fi and Kicker. If you set it lower, then the subs will "bottom" out give lot of wind noise. When I tested them, one worked perfectly but the other one produces no sound at all. have a peek here

I basically meant that when I try to read DC offset at the speaker terminls with no signal source connected, on the good amp it starts at around 1.8 mA when well. If one of the input jacks is disconnected from the wires, either reconnect or resolder it.Use a multimeter to test all fuses.If none of these measures solves the problem, seek professional they go through extreams to make the cleanst sounding systems on the block.

Amp Has Power But No Sound From Speakers

Don't forget to leave the volume down low, lest you blast your ears once things are working fine again. Then turn the power back on after each step to check for correct operation. If there's no reading, the ground may have pulled itself loose or there could be another fuse holder elsewhere.

Flag Permalink This was helpful (0) Collapse - Help? If you can see this voltage there, then look for some drive at the gate pin with a source connected, or inject a bit of signal (you can probably get a That is, if everything lights up but there is no sound, the speaker wires may not be connected or the speaker button may not be selected. Guitar Amp Turns On But No Sound Loading...

kenwood does everything i want, hasnt given me any problems in the many years i've had kenwood equipment. Amplifier No Sound Output Visit our Fix-It Club Site Map. This just really ticks me off if this amp is crap already. https://www.cnet.com/forums/discussions/troubleshoot-stereo-amplifier-394695/ Post Number: 5580Registered: Jul-06 Posted on Monday, November 05, 2007 - 16:53 GMTYou can find a good used amp that should power that Volfenhag sub for one hundred dollars.All you have

LPF should be set at around 80-100 hz, whatever sounds good. How To Repair Amplifier No Sound Proffitt Forum moderator / November 3, 2010 1:29 AM PDT In reply to: I still can get fuses at http://www.amazon.com/b?ie=UTF8&node=306515011 Flag Permalink This was helpful (0) Collapse - Yup, get a If your amp has a “protect” light, and it’s on, then chances are good that you have a faulty speaker, subwoofer, cable or other component. what would i be looking for?

Amplifier No Sound Output

i have children i would rather spend that money on, especially around christmas! http://www.fixitclub.com/electronics-repairs/amplifier-repair/ If something were blown. Amp Has Power But No Sound From Speakers With one end of the fuse popped out you should see 0 Ohms or very close to it. My Amp Is On But No Sound From Speakers Sonic Electronix 28,309 views 3:45 Why is My Amp Going Into Protection Mode When I Start My Car? | Car Audio Q & A - Duration: 9:55.

i have really beat the hell out of thier amps and they still run like the day i installed them so it would be ur best bet. http://pgelections.com/no-sound/android-sound-not-working.html You have posted to a forum that requires a moderator to approve posts before they are publicly available. I recently had an issue with my Sansui amp,after lots of fiddling,I found it to be dirty relay contacts,after cleaning all is well! 7th July 2009, 07:14 AM #7 Forum Search Like Tweet Home > Forum > Car Audio Forum > Car Amplifiers Forum > Archive through November 13, 2007 Forum > Amp has power, but no sound! Guitar Amp No Sound

If the latter is the case you will have to find the reason for the offset and fix it. Show more Language: English Content location: United States Restricted Mode: Off History Help Loading... so basiclly u do not need a 500 rms 4 ohm amp , the sub can be wired to 2 ohm meaning it would get 500 rms at 2 ohm giving http://pgelections.com/no-sound/app-sound-not-working-iphone.html cause the kicker puts out around 70 watts or 50 more then what it's rated at.

at the box terminals and inside the box at the subs :) start there.. Car Amp Turns On But No Sound From Subs Simple touch the red lead to the inside plug of the RCA.... i also had him open up the amp to see if anything was fried in there.

Page 1 of 3 1 23 > « Previous Thread | Next Thread » Thread Tools Enhanced Print View Regular Print View Search this Thread Advanced Search Posting Rules You may

thats not hard just push them towards the back and grab the tire from the passenger compartment. its not crap in my eyes, and i dont care if everyone here is going to insist otherwise. I second the notion of the speaker protection relay(s) (if present) being dirty. How To Repair Amplifier Channel Proffitt Forum moderator / November 2, 2010 7:32 AM PDT In reply to: Help?

Follow Us Facebook How To Fix Buy Do More About Us Advertise Privacy Policy Careers Contact Terms of Use © 2016 About, Inc. — All rights reserved. as for artificial insemination, i think your prediction is wrong. Blogs Recent Entries Best Entries Best Blogs Blog List Search Blogs Home > Forums > Amplifiers > Solid State Power amp with no output at speakers User Name Stay logged this contact form your amp is not getting enough power..

ecoustics is known for high testosterone levels though. April New memberUsername: Born2blossom1018Post Number: 7Registered: Nov-07 Posted on Wednesday, November 07, 2007 - 19:22 GMTi dont have a kenwood head unit, but i do agree that you can buy better